Details
  • Last release: 1.0.0
  • 5 months ago

Unofficial Deezer Desktop Client

Dependencies
  • HD_Station >= 3.2.6
  • HD_Station < 6.0.0

QTS
Requires QTS 4.2.1 or later

Models
TS-NASX86 64bits

Thanks for your support
No older version