Details
  • Last release: 66.0.3
  • 2 months ago

Web Browser (French Version)

Dependencies
  • HD_Station >= 3.2.2
  • HD_Station < 6.0.0

QTS
Requires QTS 4.2.1 or later

Models
TS-NASX86 64bits

Thanks for your support
  • 65.0.0 Released 5 months ago ( 31-01-2019 )
    Dependencies:
    • HD_Station >= 3.2.2
    • HD_Station < 6.0.0
  • 63.0.3 Released 7 months ago ( 28-11-2018 )
    Dependencies:
    • HD_Station >= 3.2.2
    • HD_Station < 6.0.0