Details
  • Last release: 3.7.3
  • 7 months ago

FileZilla FTP Client for HDStation

Dependencies
  • HD_Station >= 3.0.0
  • HD_Station < 4.0.0

QTS
Requires QTS 4.2.1 or later

Models
TS-NASX86 64bits

Thanks for your support
No older version