This is share svg Share this item

Snappy Mail (Apache80)

Simple, modern & fast web-based email client.
The drastically upgraded & secured fork of RainLoop Webmail Community edition.

https://github.com/the-djmaze/snappymail

This fork of RainLoop has the following changes:

Privacy/GDPR friendly (no: Social, Gravatar, Facebook, Google, Twitter, DropBox, OwnCloud, X-Mailer)
Admin uses password_hash/password_verify
Auth failed attempts written to syslog
Added Fail2ban instructions
ES2018
PHP 7.3+ required
PHP mbstring extension required
PHP replaced pclZip with PharData and ZipArchive
Dark mode
Added option to remove background/font colors from messages for real "dark mode"
Removed BackwardCapability (class \RainLoop\Account)
Removed ChangePassword (re-implemented as plugin)
Removed POP3 support
Removed background video support
Removed Sentry (Application Monitoring and Error Tracking Software)
Removed Spyc yaml
Replaced gulp-uglify with gulp-terser
CRLF => LF line endings
Embed boot.js and boot.css into index.html
Ongoing removal of old JavaScript code (things are native these days)
Added modified Squire HTML editor as replacement for CKEditor
Updated Sabre/VObject
Split Admin specific JavaScript code from User code
Split Sieve specific JavaScript code from User code
JSON reviver
Better memory garbage collection management
Added serviceworker for Notifications
Added advanced Sieve scripts editor
Slimmed down language files
Replaced webpack with rollup
No user-agent detection (use device width)
Added support to load plugins as .phar
Replaced old Sabre library
AddressBook Contacts support MySQL/MariaDB utf8mb4
Added Fetch Metadata Request Headers checks
Reduced excessive DOM size
Support Kolab groupware
Support IMAP RFC 2971 ID extension
Support IMAP RFC 5258 LIST-EXTENDED
Support IMAP RFC 5464 METADATA
Support IMAP RFC 5819 LIST-STATUS
Support IMAP RFC 7628 SASL OAUTHBEARER aka XOAUTH2
Support IMAP4rev2 RFC 9051
Support Sodium and OpenSSL for encryption
Much better PGP support
Supported browsers
This fork uses downsized/simplified versions of scripts and has no support for Internet Explorer nor Edge Legacy. Supported are:

Chrome 69+
Edge 79+
Firefox 78+
Opera 56+
Safari 12+

TIP ME !!
Your gratitude and finance will help me to continue integration of this QPKG and maintain up to date versions.


www.paypal.me/qoolbox



Contact the Author